发布
  • 注册
  • 汇编写法 汇编写法 关注:321 内容:190

    调用函数_自动堆栈、调用call的shellcode使用

  • 查看作者
  • 打赏作者
  • 当前位置: 桔子岛 > 汇编写法 > 正文
  • 31
  • 汇编写法
  • LV.21
    至尊会员
    害羞
    .版本 2
    
    .子程序 调用函数_自动堆栈, 长整数型, 公开, 调用call的shellcode使用
    .参数 调用数据, 字节集
    .参数 rsp, 整数型, 可空
    
    .如果真 (是否为空 (rsp) = 真)
        rsp = g_RSP
    .如果真结束
    .如果真 (调用数据 [取字节集长度 (调用数据)] = 195)
        调用数据 [取字节集长度 (调用数据)] = 144
    .如果真结束
    调用数据 = { 72, 129, 236 } + 到字节集 (到整数 (rsp)) + 调用数据 + { 72, 129, 196 } + 到字节集 (到整数 (rsp))
    返回 (调用函数_正常 (调用数据))

    水贴是注定孤独的旅行,路上少不了吐槽和嘲笑。但那又怎么样,哪怕经验暴涨,我也要抢的漂亮!我是水神,我为自己带盐,偶尔也带块洋芋粑。

    关关雎鸠,在河之洲。窈窕淑女,君子好逑。

    回复
    LV.9
    SVIP1
    哈哈哈

    我在最没有能力的年纪,遇见了最想照顾一生的人。

    回复
    LV.9
    SVIP1
    介是神马?!!

    跌跌撞撞的成长,又美又疼才是本质。

    回复
    哈哈哈

    请你,驯养我吧

    回复
    众里寻他千百度,蓦然回首在这里!

    你看这个面他又长又宽~

    回复
    LV.9
    SVIP1
    这个逼装的我给82分,剩下的用666的方式打给你!

    相信自然,也相信自己。

    回复
    LV.9
    SVIP1
    楼猪V5啊

    I'm nothing without you.

    回复
    众里寻他千百度,蓦然回首在这里!

    历史的发展是不以人的意志为转移的。

    回复
    ……

    对未来的真正慷慨,是把一切献给现在。

    回复
    这么强,支持楼主,佩服

    义人的口谈论智慧,他的舌讲说公平

    回复

    请登录之后再进行评论

    登录
  • 任务
  • 动态
  • 帖子间隔 侧栏位置: