发布
  • 注册
  • 汇编写法 汇编写法 关注:321 内容:190

    未央词条Call

  • 查看作者
  • 打赏作者
  • 当前位置: 桔子岛 > 汇编写法 > 正文
  • 32
  • 汇编写法
  • LV.21
    至尊会员
    害羞
    .版本 2
    
    .子程序 词条Call, 文本型
    .参数 指针, 长整数型
    .局部变量 局_Code, 字节集
    .局部变量 返回地址, 长整数型
    .局部变量 首, 长整数型
    .局部变量 尾, 长整数型
    .局部变量 次数, 整数型
    .局部变量 i, 整数型
    .局部变量 文本, 文本型
    .局部变量 文本2, 文本型
    .局部变量 词条空白, 长整数型
    .局部变量 offset, 整数型
    
    .如果真 (词条空白 = 0)
        词条空白 = 驱动.申请内存 (进程PID, 200)
    .如果真结束
    局_Code = { 65, 185, 96, 0, 0, 0 }
    局_Code = 局_Code + { 73, 184 } + 到字节集 (到长整数 (指针))
    局_Code = 局_Code + { 186 } + 到字节集 (到整数 (1277))
    局_Code = 局_Code + { 72, 185 } + 到字节集 (到长整数 (#商店基址))
    局_Code = 局_Code + { 72, 139, 9 }
    局_Code = 局_Code + { 72, 184 } + 到字节集 (到长整数 (#打开界面CALL))
    局_Code = 局_Code + { 255, 208 }
    局_Code = 局_Code + { 72, 187 } + 到字节集 (到长整数 (词条空白))
    局_Code = 局_Code + { 72, 137, 3 }
    局_Code = { 72, 131, 236, 48 } + 局_Code + { 72, 131, 196, 48 } + { 195 }
    CallBack.调用函数_自动堆栈 (局_Code)
    返回地址 = 读长整数型 (词条空白)
    offset = 进制_十六到十 (“418”) + 8
    首 = 读长整数型 (返回地址 + offset)
    尾 = 读长整数型 (返回地址 + offset + 8)
    次数 = (尾 - 首) ÷ 184
    .计次循环首 (次数, i)
        .如果真 (读长整数型 (读长整数型 (返回地址 + offset) + (i - 1) × 184 + 32) > 0)
            文本 = 编码_Unicode到Ansi (读字节集 (读长整数型 (读长整数型 (返回地址 + offset) + (i - 1) × 184 + 32), 100))
            .如果真 (文本 ≠ “”)
                文本2 = 文本2 + 文本 + “|”
            .如果真结束
    
        .如果真结束
    
    .计次循环尾 ()
    返回 (文本2)

    楼主辛苦了,谢谢楼主

    相信自然,也相信自己。

    回复
    这个逼装的我给82分,剩下的用666的方式打给你!

    亲爱的,你的心在哪里?

    回复
    介是神马?!!

    过去已成过去,将来还是将来,而我们能改变的只有现在。

    回复
    666666666

    与绝望~和睦相处。

    回复
    LV.6
    SVIP1
    ……

    高调做事,低调做人。

    回复
    水贴是注定孤独的旅行,路上少不了吐槽和嘲笑。但那又怎么样,哪怕经验暴涨,我也要抢的漂亮!我是水神,我为自己带盐,偶尔也带块洋芋粑。

    没有光明是不幸的么?不,需要光明才是真正的不幸。

    回复
    楼主辛苦了,谢谢楼主

    如果命运是一条孤独的河流,谁会是你灵魂的摆渡人?

    回复
    LV.7
    楼主辛苦了,谢谢楼主,楼主好人一生平安!

    花火みたいな綺麗な人になれば 良かったかな

    回复
    介是神马?!!

    明天会吹拂着明天的风。

    回复
    LV.9
    SVIP1
    确实不错

    我年轻,我傲娇。

    回复

    请登录之后再进行评论

    登录
  • 任务
  • 动态
  • 帖子间隔 侧栏位置: